
 

Signal Processing Toolbox 
Release Notes

The “Signal Processing Toolbox 6.2 Release Notes” on page 1-1 describe 
the changes introduced in the latest version of the Signal Processing 
Toolbox. The following topics are discussed in these Release Notes:

• “New Features” on page 1-2

• “Major Bug Fixes” on page 1-6

• “Platform Limitations” on page 1-7

• “Upgrading from an Earlier Release” on page 1-8

• “Known Software and Documentation Problems” on page 1-10

The Signal Processing Toolbox Release Notes also provide information 
about recent versions of the product, in case you are upgrading from a 
version that was released prior to Release 14.

• “Signal Processing Toolbox 6.1 Release Notes” on page 2-1

• “Signal Processing Toolbox 6.0 Release Notes” on page 3-1

• “Signal Processing Toolbox 5.1 Release Notes” on page 4-1

• “Signal Processing Toolbox 5.0 Release Notes” on page 5-1

Printing the Release Notes
If you would like to print the Release Notes, you can link to a PDF version.



 

2



iii

Contents

1
Signal Processing Toolbox 6.2 Release Notes

New Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-2
Spectrum Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-2
Dspdata Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-2
Options Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-3
Filter States Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-3
Enhancements to Discrete-time Filter Objects  . . . . . . . . . . . . .  1-3
Enhancements to Window Objects . . . . . . . . . . . . . . . . . . . . . . .  1-4
Enhancement to Spectral Estimation Functions . . . . . . . . . . . .  1-4
FDATool Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-4
FVTool Enhancement  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-5
New/Renamed Filter Design Functions . . . . . . . . . . . . . . . . . . .  1-5
New Demos  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-5

Major Bug Fixes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-6

Platform Limitations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-7
FDATool — 800 x 600 Resolution . . . . . . . . . . . . . . . . . . . . . . . .  1-7
Graphical User Interfaces on HP Platforms  . . . . . . . . . . . . . . .  1-7

Upgrading from an Earlier Release . . . . . . . . . . . . . . . . . . . . .  1-8
Grandfathered Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-8
Renamed Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1-8
Discrete-time Filter States Property  . . . . . . . . . . . . . . . . . . . . .  1-8

Known Software and Documentation Problems  . . . . . . . .  1-10

2
Signal Processing Toolbox 6.1 Release Notes

New Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-2
Discrete-Time Filter Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-2



iv

FDATool Enhancements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-2
FVTool Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-3
SPTool Enhancement—Filter Viewer . . . . . . . . . . . . . . . . . . . . .  2-3

Major Bug Fixes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-4

Upgrading from an Earlier Release . . . . . . . . . . . . . . . . . . . . .  2-5
Uninstall Previous Versions Before Installing Version 6.1 . . . .  2-5
Filter Structure Name Changes  . . . . . . . . . . . . . . . . . . . . . . . . .  2-5
New Warning Message for DFILT Filter method  . . . . . . . . . . .  2-6

3
Signal Processing Toolbox 6.0 Release Notes

New Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-2
Digital Filter Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-2
Window Design and Analysis Tool  . . . . . . . . . . . . . . . . . . . . . . .  3-3
Window Visualization Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-3
Window Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-3
Window Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
New Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
Gaussian Filter Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
New Analysis Functions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
Improvements to grpdelay . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
stepz Function  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
digitrevorder Function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4
FDATool Enhancements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-5
FVTool Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-6
Demos . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-7

Major Bug Fixes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-8

Platform Limitations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-9
FDATool — 800 x 600 Resolution . . . . . . . . . . . . . . . . . . . . . . . .  3-9

Upgrading from an Earlier Release . . . . . . . . . . . . . . . . . . . .  3-10
Obsolete Function  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-10



v

4
Signal Processing Toolbox 5.1 Release Notes

New Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-2
Filter Visualization Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-2
New Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-3
bitrevorder  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-4
downsample/upsample . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-4
filternorm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-4
goertzel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-4
New Signal Demo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-4

Enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-5
FDATool Enhancements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-5
SPTool Enhancement . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-5
Enhanced Functions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-6

Major Bug Fixes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-7
Bug Fixes Incorporated from Release 12.0 . . . . . . . . . . . . . . . . .  4-7

5
Signal Processing Toolbox 5.0 Release Notes

New Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-2
Filter Design & Analysis Tool (FDATool) . . . . . . . . . . . . . . . . . .  5-3
SPTool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-4
Spectrogram Demo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-5
Automatic Order Adjustment in FIR Filter Functions  . . . . . . .  5-5
grpdelay  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-6
hilbert . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-6
lpc  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-6
xcorr  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-6

Major Bug Fixes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-7

Upgrading from an Earlier Release . . . . . . . . . . . . . . . . . . . . .  5-8
Changes to remez . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5-8



vi Contents



 

1
Signal Processing Toolbox 
6.2 Release Notes

New Features    .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-2
Spectrum Objects    .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-2
Spectrum Data Objects   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-2
Options Objects   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-3
Filter States Objects   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-3
Enhancements to Discrete-time Filter Objects .   .   .   .   .   .   .   1-3
Enhancements to Window Objects .   .   .   .   .   .   .   .   .   .   .   .   1-4
Enhancement to Spectral Estimation Functions  .   .   .   .   .   .   1-4
FDATool Enhancements .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-5
FVTool Enhancement .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-5
New/Renamed Filter Design Functions .   .   .   .   .   .   .   .   .   .   1-5
New Demos  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-5

Major Bug Fixes   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-6

Platform Limitations  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-7
FDATool — 800 x 600 Resolution  .   .   .   .   .   .   .   .   .   .   .   .   1-7
Graphical User Interfaces on HP Platforms  .   .   .   .   .   .   .   .   1-7

Upgrading from an Earlier Release    .   .   .   .   .   .   .   .   .   1-8
Grandfathered Function .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-8
Renamed Functions    .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1-8
Discrete-time Filter States Property .   .   .   .   .   .   .   .   .   .   .   1-8

Known Software and Documentation Problems  .   .   .   . 1-10



1 Signal Processing Toolbox 6.2 Release Notes

1-2

New Features
This section summarizes the new features and enhancements introduced in the 
Signal Processing Toolbox 6.2.

This section is organized into the following subsections:

• “Spectrum Objects” on page 1-2

• “Dspdata Objects” on page 1-2

• “Options Objects” on page 1-3

• “Filter States Objects” on page 1-3

• “Enhancements to Discrete-time Filter Objects” on page 1-3

• “Enhancements to Window Objects” on page 1-4

• “Enhancement to Spectral Estimation Functions” on page 1-4

• “FDATool Enhancements” on page 1-4

• “FVTool Enhancement” on page 1-5

• “New/Renamed Filter Design Functions” on page 1-5

Spectrum Objects
The Signal Processing Toolbox 6.2 adds a new spectrum object. Spectrum 
objects contain parameter information for a particular spectral estimation 
method (e.g., spectrum.welch). This object provides an improved way to view 
and manipulate spectral estimation parameters. See the spectrum reference 
page and the associated estimation method reference pages for more 
information.

Dspdata Objects
A new data object dspdata has been added. These data objects contain 
parameter information for spectral data. Available types of data objects are 
dspdata.msspectrum, dspdata.psd, and dspdata.pseudospectrum. These 
objects contain the mean-square spectrum data, the power spectral density 
data, and the pseudospectrum data, respectively. With these objects, you can 
apply methods that calculate certain values or modify the data, such as 
computing the average power, centering the DC value, converting the spectrum 
between one-sided and two-sided, and normalizing the frequency. You can plot 
the data in a new Spectral Analysis plot. See dspdata for information.



New Features

1-3

Options Objects
A new options object dspopts has been added. This object contains optional 
parameter information for spectrum objects. You create options objects via 
methods on other objects. See dspopts for information.

Filter States Objects
A new filter states object filtstates with two properties—Numerator and 
Denominator, that contain the filter states for an IIR Direct-form I filter, has 
been added. The states property of a dfilt.df1, dfilt.df1t, dfilt.df1sos, or 
dfilt.df1tsos filter now contains a filtstates.dfiir object, instead of a 
double vector. See filtstates for more information.

Note that you cannot change the values in the Numerator or Denominator 
using this syntax:

Hd.states.numerator = [<data>]

Note  The sign of the Denominator states for dfilt.df1t and dfilt.df1tsos 
is negated from what it was in previous versions. Refer to the structure 
diagrams shown on the reference pages.

If you use the double command on a filter states object to get a vector of 
double-precision values of the numerator and denominator, the numerator 
values are listed first, followed by the denominator values. In previous 
versions, the denominator values were listed first.

States saved for SOS objects in previous versions cannot be loaded into the 
current version.

Enhancements to Discrete-time Filter Objects
• The leading coefficient of the denominator (a0) can not be set to zero.

• New methods have been added to dfilt objects:

- fcfwrite—writes an ASCII filter coefficient file.

- info—displays filter structure, order, stability and linear phase 
information.
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• The terminology used for multistage and second-order sections (SOS) filters 
has been clarified and some dfilt method names have been changed. SOS 
filters have sections, where sections compose a single filter. Cascade and 
parallel filters have stages, where each stage is a separate filter. See the 
“Methods” section of the dfilt reference page for information on methods 
related to sections and stages. The new or renamed methods are

- addstage—adds a stage to a parallel or cascade filter object.

- nstages—returns the number of stages in the filter.

- removestage—removes a stage from a parallel or cascade filter object.

- setstage—overwrites a stage of a parallel or cascade filter object.

Enhancements to Window Objects
Two new methods have been added to sigwin objects:

• winwrite—writes an ASCII file containing window weights

• info—displays information about the window object

Note  To obtain command line help for Signal Toolbox objects, type help 
objectname or help objectname/classname or help objectname/
methodname. For example, to display help on the psd class of dspdata, type 
help dspdata/psd and for help on the average power method, type help 
dspdata/avgpower.

Enhancement to Spectral Estimation Functions
All of the spectral estimation functions (pburg, pcov, peig, periodogram, 
pmcov, pmtm, pmusic, pwelch, and pyulear) now use the new Spectral Analysis 
plot when no output arguments are specified. For an example of this plot, see 
the spectrum reference page.

FDATool Enhancements
• A new graphical Pole/Zero Editor panel has been added. You can 

graphically edit the filter (move, add, and delete poles/zeros) and see the 
resulting effect on your filter design.
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• File->Export changes include adding the ability to export the filter directly 
to SPTool, exporting an ASCII coefficient file instead of a text file, exporting 
cascades and parallel structures, and general improvements to the dialog 
box. 

• FIR Constrained Least Squares (fircls) and complex and nonlinear-phase 
equiripple FIR (cfirpm) filters have been added as design methods.

• A Filter Manager has been added. You can use the Filter Manager to store 
and recall multiple filters in a single FDATool session. You can also use it to 
cascade filters easily.

• The Analysis Parameters dialog box has been reorganized and simplified. 
The Frequency Units field has been removed and a Normalized Frequency 
checkbox has been added. (This also applies to FVTool.)

FVTool Enhancement
From the command line, you can change the sampling frequency (Fs) for the 
filter(s) in FVTool. See the Controlling FVTool from the MATLAB Command 
Line section of fvtool for more information.

New/Renamed Filter Design Functions 
See “Renamed Functions” on page 1-8 for information.

New Demos
Two new demos have been added:

• Waveform Generation — generates common waveforms, such as pulse 
trains.

• DTMF — generates telephone pad tones.
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Major Bug Fixes
The Signal Processing Toolbox includes several bug fixes made since Version 
6.1. This section describes the particularly important Version 6.2 bug fixes.

If you are viewing these Release Notes in PDF form, please refer to the HTML 
form of the Release Notes, using either the Help browser or the MathWorks 
Web site and use the link provided.

If you are upgrading from a release earlier than Release 13 with Service Pack 
1, then you should see the bug fixes summary in the Signal Processing Toolbox 
6.1 Release Notes.
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Platform Limitations

FDATool — 800 x 600 Resolution
On all platforms, FDATool requires a screen resolution of at least 800 x 600.

Graphical User Interfaces on HP Platforms
A number of GUI controls (for example, radio buttons and check boxes) do not 
display correctly on HP platforms. For more details, refer to the latest 
MATLAB Release Notes. This problem primarily affects FDATool.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox 6.1 to Version 6.2.

If you are upgrading from Version 6.0 or earlier, see “Upgrading from an 
Earlier Release” on page 2-5 in the Signal Processing Toolbox 6.1 Release 
Notes.

Grandfathered Function
The psd and psdplot functions have been grandfathered. To obtain a plot of a 
power spectral density, use the psd method on a spectrum object or store your 
data in a dspdata.psd object and use the plot method.

The power spectrum estimate via maximum entropy method (pmem) has been 
grandfathered. To obtain this estimate, use spectrum.yulear.

Renamed Functions
The following functions have been grandfathered and renamed.

*tfestimate, cpsd, and mscohere have new default values and, in some cases, 
produce different results. Refer to their reference pages for more information.

Discrete-time Filter States Property
In previous version of the Signal Processing Toolbox, the output of the states 
property of a dfilt.df1, dfilt.df1t, dfilt.df1sos or dfilt.df1tsos object 

Old Name New Name

remez firpm

cremez cfirpm

remezord firpmord

tfe tfestimate*

csd cpsd*

cohere mscohere*
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was a vector of doubles. In the current version, the output is a filtstates 
object, Hs. To obtain a vector of doubles from the Hs object, use

double(Hs)

You cannot load the states of an SOS object saved in a previous versions into 
the current version.

Note that the order of the double-precision numerator and denominator values 
differs from the order in previous versions. In the current version, numerator 
values are listed first, followed by denominator values.

Note also that the sign of the Denominator states for dfilt.df1t and 
dfilt.df1tsos is negated from what it was in previous versions. Refer to the 
structure diagrams shown on the reference pages.
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Known Software and Documentation Problems
This section includes a link to a description of known software and 
documentation problems in Version 6.2.

If you are viewing these Release Notes in PDF form, please refer to the HTML 
form of the Release Notes, using either the Help browser or the MathWorks 
Web site and use the link provided.
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New Features
This section summarizes the new features and enhancements introduced in the 
Signal Processing Toolbox.

If you are upgrading from a release earlier than Release 13, then you should 
see “Upgrading from an Earlier Release” on page 2-5.

This section is organized into the following subsections:

• “Discrete-Time Filter Objects” on page 2-2

• “FDATool Enhancements” on page 2-2

• “FVTool Enhancements” on page 2-3

• “SPTool Enhancement—Filter Viewer” on page 2-3

Discrete-Time Filter Objects
Several new features have been added to discrete-time filter objects. For more 
information, see the dfilt reference page.

• New properties—You can now include initial conditions in your dfilt objects 
with the States and ResetBeforeFiltering properties. 

• New structure—An overlap-add FFT FIR filter structure has been added. 
See dfilt.fftfir.

• New method—The block method creates a Simulink block of the dfilt 
object. This method is available only if the DSP Blockset is installed.

• Array handling—Some dfilt methods can now take an array of objects as 
input.

• freqz method—The S output has been removed from the dfilt freqz 
method.

FDATool Enhancements
• Creating M-code—You can now generate an M-file that includes code for the 

filter designed in FDATool. Use Generate M-file on the Targets menu. Note 
that this option is available only for designed filters and is disabled if you 
perform any other action on the filter.
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• Zooming—Zoom menu items have been moved from the Tools menu to the 
View menu. Zooming in the x- and y-directions has been added. (This change 
also applies to FVTool, WinTool, and WVTool.)

• Complex filters—You can load complex filters into FDATool and view their 
step and impulse responses. (This change also applies to FVTool.)

• Exporting filters as text files—Exported text files now include more 
information in the file header (toolbox version number and filter structure 
information). Only coefficients can be exported as text files.

FVTool Enhancements
• Command line access—You can now control FVTool from the command line 

in the same manner as you control other figures using gcf. For example, you 
can turn on and specify the legend strings from the command line. See the 
fvtool reference page for more information.

• Overlaying responses—You can add a second response to the analysis 
display.

• Phase Delay—The phase delay response has been added to the available 
filter analyses. 

• Filter Information—Detailed filter information has been added to the filter 
analyses.

• Boundary masks—You can turn on filter specification lines in the analysis 
display to view the ideal filter response based on your filter specifications. 
Note that these lines can be turned on only for displays showing the same 
units as the units in which the filter was designed (e.g., Magnitude(dB) for 
filters designed in dB, Magnitude and Zero-phase for filters designed in 
linear).

SPTool Enhancement—Filter Viewer
Selecting the filter viewer in SPTool now starts FVTool.
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Major Bug Fixes
You can see a list of the particularly important Version 6.1 bug fixes. 

If you are viewing these Release Notes in PDF form, please refer to the HTML 
form of the Release Notes, using either the Help browser or the MathWorks 
Web site and use the link provided.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox Version 6.0 to Version 6.1.

Uninstall Previous Versions Before Installing 
Version 6.1
Verson 6.1 of the toolbox relocates some files to improve performance, so you 
must completely uninstall all earlier version of the Signal Processing Toolbox 
before installing the R13+ version.

Caution  Uninstalling the toolbox deletes all files in the $MATLAB/toolbox 
signal directory. Backup any files you may need to another directory before 
performing the uninstall steps.

Close MATLAB before attempting to uninstall the toolbox.

On Windows systems, use the MATLAB Uninstaller which you can access 
from Start->Programs-> MATLAB 6.5-> Uninstall MATLAB 6.5. Select the 
Signal Processing Toolbox from the Uninstall Product List.

On Unix systems, use:

rm -rf $MATLAB/toolbox/signal

where $MATLAB represents the name of your top-level MATLAB installation 
directory. 

Filter Structure Name Changes
The following changes have been made to the names of some filter structures.

Old Name New Name

direct form direct-form
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New Warning Message for DFILT Filter method
If you pass initial condtions using the dfilt filter method, a warning 
message is displayed. The preferred way to pass initial conditions to a dfilt is 
with the new States method.

auto-regressive autoregressive

moving average moving-average

Old Name New Name
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New Features
This section summarizes the new features and enhancements introduced in the 
Signal Processing Toolbox.

If you are upgrading from a release earlier than Release 12.1, then you should 
see “Upgrading from an Earlier Release” on page 3-10.

This section is organized into the following subsections:

• “Digital Filter Objects” on page 3-2

• “Window Design and Analysis Tool” on page 3-3

• “Window Objects” on page 3-3

• “Window Function” on page 3-4

• “New Windows” on page 3-4

• “Gaussian Filter Function” on page 3-4

• “New Analysis Functions” on page 3-4

• “Improvements to grpdelay” on page 3-4

• “stepz Function” on page 3-4

• “digitrevorder Function” on page 3-4

• “FDATool Enhancements” on page 3-5

• “FVTool Enhancements” on page 3-6

• “Demos” on page 3-7

Digital Filter Objects
The Signal Processing Toolbox 6.0 adds a new way of creating, viewing, and 
modifying discrete-time filters using objects. With the new discrete-time filter 
object, dfilt, you can use object-oriented programming, such as calling 
constructors to create specific types of filter objects, using get to view the filter 
properties, and using set to change filter properties. See the dfilt reference 
page for detailed information on this new object.

Some advantages of using dfilt objects instead of vectors of coefficients [b,a] 
are:

• The filter’s structure is part of the object.
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• The filter function can be run on any structure without converting to 
transfer function form.

• The filter is contained in a single object instead of two vectors. This simplifies 
passing the filter to another function or GUI. 

• freqz, grpdelay, impz, phasez, stepz, and zplane are now overloaded 
methods. If you pass a dfilt to any of them or if you do not specify any 
outputs, the filter response is displayed in the Filter Visualization Tool 
(fvtool), where you can access other filter analyses. If you pass filter 
coefficients to them, the figure is displayed in a default figure window. 

• You can change a filter’s characteristics quickly and easily by changing one 
or more of its properties.

• You can double-click on a dfilt object in the MATLAB Workspace Browser 
to display the Property Inspector.

• You can highlight a dfilt and right-click in the MATLAB Workspace 
Browser to launch the Filter Visualization Tool. 

Window Design and Analysis Tool
The new Window Design and Analysis Tool (wintool) is a GUI that provides 
an easy way to design and compare spectral windows. All of the windows 
provided in the Signal Toolbox are available in wintool. You start wintool 
from the MATLAB command line. See the wintool reference page for more 
information.

Window Visualization Tool
A new tool for viewing windows, wvtool, has been added. 

Window Objects
A new way of creating, viewing, and modifying windows using objects has been 
added. The new window object, sigwin, uses object-oriented programming. See 
“Digital Filter Objects” above for advantages of using objects. See the sigwin 
reference page for detailed information on this new object. 
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Window Function
Using the window function without specifying an input now launches the 
Window Design and Analysis Tool (wintool).

New Windows
Two new window functions have been added:

• parzenwin computes a Parzen window. This window is also known as a 
de la Vallé-Poussin window.

• flattopwin computes a Flat Top window.

Gaussian Filter Function
The new function, firgauss designs an FIR Gaussian digital filter. 

New Analysis Functions
Three new analysis functions have been added:

• phasedelay - computes the phase delay response of a filter

• phasez - computes the digital phase response of a filter

• zerophase - computes the zero-phase response of a filter. (Previously, this 
function, using a different syntax, was in the Filter Design Toolbox.)

Improvements to grpdelay
The grpdelay function has been updated to be more accurate for IIR filters 
with poles/zeros very close to the unit circle. This improvement is also reflected 
in the Group Delay plot in FDATool and FVTool.

stepz Function
stepz, which is also available as an overloaded dfilt method, is now available 
from the MATLAB command line. Previously, it was available only in fdatool.

digitrevorder Function
A new function, digitrevorder, allows you to pre-order a vector of filter 
coefficients.
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FDATool Enhancements
• New panel control buttons have been added on the lower left side (in a 

sidebar) to change the panel from Design Filter to Import Filter. If the Filter 
Design Toolbox is installed, Set Quantization Parameters and Transform 
Filter control buttons are also included. If the DSP Blockset is installed, a 
Realize Model control button is included to create a subsystem filter block in 
a Simulink model.

• You can specify additional filter design options in the Design panel. These 
options previously were only available from the command line.

• The Filter Visualization Tool (fvtool), which is launched with the Full View 
Analysis toolbar button or Analysis->Full View Analysis, can be linked so 
that it stays synchronized with FDATool. For more information, see the 
FVTool Enhancements section below.

• The following menu items have been added or updated

- File->Export exports vectors of filter coefficients or a dfilt filter object to 
the workspace, a text file, or a MAT file.

- File->Export to SPTool exports the current filter to SPTool.

- Edit->Undo now undoes single actions, one at a time. Undo will also undo 
the design or importing of a filter.

- Edit->Redo redoes the last action.

- Edit->Convert Structure launches a dialog box for converting the 
underlying filter structure. This dialog box is also available from a context 
menu (by right-clicking) in the Current Filter Information frame.

- Edit->Convert to Second Order Sections launches a dialog box for 
converting the filter to Second Order Sections. This dialog box is also 
available from a context menu (by right-clicking) in the Current Filter 
Information frame. (The fields in this dialog box previously were part of 
the Convert Structure dialog box.) 

- Edit->Convert to Single Section converts a second order sections filter 
back to a single section. This option is also available from a context menu 
(by right-clicking) in the Current Filter Information frame. 

The Convert to Second Order Sections dialog box now limits scaling to 
Direct form II structures only.

- Analysis->Analysis Parameters sets analysis-specific parameters for the 
filter responses. You can also access this from the context menu. You can 
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now save your preferred Analysis Parameters by clicking Save as 
Default in the Analysis Parameters dialog box.

- Analysis->Sampling Frequency sets the sampling frequency for the 
current filter.

- The Filter menu has been removed. You can access all items previously on 
this menu from the sidebar and Edit menu.

• Context menus, which you access by right-clicking, are included for setting 
the units, changing the display, setting the sampling frequency, or accessing 
the Analysis Parameters on the response plots and labels. 

• The Pole/Zero Plot can now display the number of poles /zeros in cases where 
multiple poles/zeros occur at a single point.

• A new filter design method—Maximally flat—has been added. Other new 
methods have also been added in the Filter Design Toolbox,

• To perform zero-phase analysis, right-click on the y-axis label of a Magnitude 
plot to display the context menu and select Zero-Phase, or select it in the 
Analysis Parameters dialog box. To display the corresponding phase plot, 
select Continuous Phase from the Phase context menu.

• Data markers have been enhanced so they are now movable.

• The Current Filter Information frame has been updated. The Convert 
Structure button has been removed. To convert a structure, select Convert 
Structure from the right-click context menu or from the Edit menu.

FVTool Enhancements
• FVTool can be synchronized with FDATool with the Activate FDAToolLink 

toolbar button. When activated, any changes made to the filter in FDATool 
are immediately reflected in FVTool. 

• File->FDAToolLink sets the mode for FDAToolLink. Replace current 
filter removes the filter in FVTool and replaces it with the new FDATool 
filter. Add new filter adds the FDATool filter to the current filter in FVTool 
so that multiple filters can be displayed and compared. You can also set the 
mode using the Set Link mode toolbar button.

• The Edit and Insert menus have been customized to FVTool and irrelevant 
menu items have been removed.
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• A new Tools menu, which includes edit plot and zoom options, has been 
added.

• If the Filter Design Toolbox is installed, a new analysis method, Noise 
Loading Method, has been added to the Analysis menu. Refer to the Filter 
Design Toolbox documentation for more information.

• Context menus, which you access by right-clicking, are included for setting 
the units, changing the display, or accessing the Analysis Parameters on the 
response plots and labels. 

• You can now save your preferred Analysis Parameters by clicking Save as 
Default in the Analysis Parameters dialog box. 

• You can name the filter and specify the filter’s sampling frequency with 
Sampling Frequency on the Analysis menu or by selecting Sampling 
Frequency from the context menu. If you have more than one filter, you can 
specify a different name and sampling frequency for each filter.

• To perform zero-phase analysis, right-click on the y-axis label of a Magnitude 
plot to display the context menu and select Zero-Phase, or select it in the 
Analysis Parameters dialog box. To display the corresponding phase plot, 
select Continuous Phase from the Phase context menu.

Demos
You can now launch the Window Visualization Tool (wvtool) from the Vector 
Transition demo (windtrandemo) to view the selected window.

A new Spectral Estimation demo (psddemo) has been added.

A new digital filter object demo (dfiltdemo) has been added.

The spectrogram demo (specgramdemo) has been enhanced with additional 
audio playback and visualization options.
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Major Bug Fixes
You can see a list of the particularly important Version 6.0 bug fixes. 

If you are viewing these Release Notes in PDF form, please refer to the HTML 
form of the Release Notes, using either the Help browser or the MathWorks 
Web site and use the link provided.
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Platform Limitations

FDATool — 800 x 600 Resolution
On all platforms, FDATool requires a screen resolution of at least 800 x 600.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox 5.1 to Version 6.0.

Obsolete Function
freqzplot is now an obsolete function. Although it is included in Release 13 for 
backward compatibility, it might be removed in a future release. Functions 
that previously used freqzplot now use fvtool to display plots. 
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New Features
This section introduces the new features added in the Signal Processing 
Toolbox 5.1 since the Signal Processing Toolbox 5.0 (Release 12.0). 
Enhancements are described in the next section.

For information about Signal Processing Toolbox features that are 
incorporated from recent releases, see “New Features” on page 5-2 in the 
Signal Processing Toolbox 5.0 Release Notes.

The Signal Processing Toolbox 5.1 provides a number of new features and 
enhancements, and a completely new facility for analyzing filters, the Filter 
Visualization Tool.

This section is organized into the following subsections:

• “Filter Visualization Tool” on page 4-2

• “New Windows” on page 4-3

• “bitrevorder” on page 4-4

• “downsample/upsample” on page 4-4

• “filternorm” on page 4-4

• “goertzel” on page 4-4

• “New Signal Demo” on page 4-4

Filter Visualization Tool
The new Filter Visualization Tool (fvtool) groups all the filter analysis 
functions, such as magnitude, phase, impulse response, etc., into a single 
window where you can easily switch between analyses, add annotations, and 
print your filter response.
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New Windows
Six new window functions and a general window function have been added to 
the Signal Processing Toolbox. One window has been renamed. The new 
windows are:

• Bartlett-Hann (barthannwin)

• Blackman-Harris (blackmanharris)
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• Bohman (bohmanwin)

• Gaussian (gausswin)

• Nuttall’s Blackman-Harris (nuttallwin)

• Tukey (tapered cosine) (tukeywin)

The general window function is an alternate way to specify any Signal 
Processing Toolbox window.

The rectangular (boxcar) window function has been renamed rectwin. For 
compatibility, boxcar will continue to work in this release.

bitrevorder
The new bitrevorder function returns input data in bit-reversed order.

downsample/upsample
The new downsample and upsample functions decrease and increase the 
sampling rate of a signal, respectively.

filternorm
The new filternorm function computes the 2-norm or inf-norm of a digital 
filter.

goertzel
The new goertzel function implements the Goertzel algorithm, which is an 
alternate method of computing the DFT.

New Signal Demo
A new demo, Vector Transition Processing Using Spectral Windows, has been 
added. This demo is interactive and demonstrates how to smooth the transition 
between two vectors by using various spectral windows.
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Enhancements
This section describes the Signal Processing Toolbox enhancements and is 
organized into the following subsections:

• “FDATool Enhancements” on page 4-5

• “SPTool Enhancement” on page 4-5

• “Enhanced Functions” on page 4-6

FDATool Enhancements
The following items have been added to the FDATool.

• The new Filter Visualization (fvtool) can be launched from Analysis->Full 
View Analysis.

• Print Preview is now an icon on the toolbar and it launches the MATLAB 
standard print preview.

• Clicking on any point on a filter plot line adds a data marker, which displays 
information about the current point.

• New windows are included in Method->FIR->Window and in the Window 
option in the Window Specifications pane.

• The ability to export filter coefficients to a C-header file (File->Create 
Header File) is included.

• The raised cosine (firrcos) filter method is a new option in the Method 
menu and in the Design Filter pane.

• A plug-in for Code Compose Studio™ IDE to provide the ability to download 
coefficients from FDATool to the Developer’s Kit for TI DSP is included.

• FDATool is integrated with DSP Blockset and is accessible from the Digital 
Filter Design block.

SPTool Enhancement
You can print preview and print your filter design in the SPTool Filter Viewer 
and Filter Designer.
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Enhanced Functions
The following functions have been enhanced in the Signal Processing Toolbox 
5.1. 

Function Enhancement

buffer Takes all MATLAB data types in addition to 
double-precision data

chirp Allows you to specify the shape (concave or convex) of a 
quadratic chirp operation

eqtflength Returns the numerator and denominator orders in 
addition to the numerator and denominator

lpc Outputs a vector of prediction error variances in addition 
to the linear prediction filter coefficients

medfilt1 Allows you to specify the matrix dimension along which 
the filter operates

sgolayfilt Allows you to specify the matrix dimension along which 
the filter operates, and it returns row output for row input. 
This is consistent with filter
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Major Bug Fixes
The Signal Processing Toolbox 5.1 includes several bug fixes, including the 
following:

• In FDATool Magnitude and Phase plot, zoom now works properly.

• In FDATool, the highpass FIR design method for Least Squares and 
Equiripple cases now uses the weights correctly when you use the Specify 
Order option.

Bug Fixes Incorporated from Release 12.0
The Signal Processing Toolbox 5.1 includes several bug fixes that were made in 
Release 12.0.
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New Features
This section introduces the new features and enhancements added in the 
Signal Processing Toolbox 5.0 since the Signal Processing Toolbox 4.3 (Release 
11.1). 

The Signal Processing Toolbox 5.0 provides a number of important 
enhancements, and a completely new facility for designing and analyzing 
filters, the Filter Design & Analysis Tool (FDATool).

This section is organized into the following subsections:

• “Filter Design & Analysis Tool (FDATool)” on page 5-3

• “SPTool” on page 5-4

• “Spectrogram Demo” on page 5-5

• “Automatic Order Adjustment in FIR Filter Functions” on page 5-5

• “grpdelay” on page 5-6

• “hilbert” on page 5-6

• “lpc” on page 5-6

• “xcorr” on page 5-6
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Filter Design & Analysis Tool (FDATool)
The Filter Design & Analysis Tool provides a simple and intuitive graphical 
interface to most of the Signal Processing Toolbox’s digital filter design 
functions.

To start the tool, type fdatool at the MATLAB command line.
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SPTool
SPTool has received a number of enhancements:

• The Signal Browser can now play a selected portion of a signal.

• The markers (rulers) have been enhanced in all component tools (Signal 
Browser, Filter Viewer, Filter Designer, and Spectrum Viewer).

• The toolbars have been enhanced in all component tools. (The new Signal 
Browser interface is shown below.)

To start the tool, type sptool at the MATLAB command line.
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Spectrogram Demo
The Spectrogram Demo (specgramdemo(y,Fs)) is a new demo that displays a 
spectrogram, a time plot, and a frequency slice of an input signal, y, assuming 
a sample rate of Fs Hz. 

Automatic Order Adjustment in FIR Filter Functions
Most of the FIR filter functions (fir1, fir2, firls, firpm, fircls, fircls1) 
now automatically increase the order of linear phase filters by 1 when 
necessary to meet the design specifications. For example, a Type II (odd order, 
symmetric) linear phase filter must have a zero at  radians. If a gain other 
than zero is instead specified at  radians in any of the above mentioned 
functions, the function adds 1 to the filter order and proceeds to design the 
higher order filter. 

A warning message is produced in the command window whenever a function 
automatically changes the filter order.

π
π
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grpdelay
The grpdelay function now returns more accurate results for IIR filters.

hilbert
The hilbert function no longer zero-pads sequences that have a 
non-power-of-two length, so the transforms are now exact.

lpc
The lpc function can now return an estimate of the prediction error variance 
(power) as a second output.

xcorr
The xcorr function can now efficiently compute the cross-correlation and 
autocorrelation of large vectors.
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Major Bug Fixes
The Signal Processing Toolbox includes several bug fixes, including the 
following descriptions (online only) of particularly important bug fixes.
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Upgrading from an Earlier Release
This section describes the upgrade issues involved in moving from the Signal 
Processing Toolbox 4.3 (Release 11.1) to the Signal Processing Toolbox 5.0. 

Changes to remez
In the Signal Processing Toolbox 5.0, the remez (changed to firpm in Release 
14) function no longer supports the 'm' option that previously executed an 
M-file variant of the function.
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